READ ME FIRST: Before opening support threads

Hello there! It’s me, your wonderfully wonderful lead developer of Socially Distant. If you’re reading this, it means you’ve run into some sort of issue with the game. That makes me sad since we try to make sure the game is as stable as possible, but these things happen. Before you open a new support thread here, let’s try and figure out what’s going on.

Common troubleshooting

Just to rule things out, let’s try a few common troubleshooting steps and see if it helps get the game working.

  1. Turn it off and on again. If you’ve had the game open for a while, and are starting to experience performance problems or other issues over time, simply restarting the game is usually enough to fix it. That being said, this could be indicative of a memory leak and should likely be reported.

  2. Run dmesg in Terminal: This command outputs the Unity log to the terminal. The Unity log provides lots of useful diagnostic messages such as run-time errors and warnings. You can run dmesg | hypervisorctl save-to-host to save the Unit log to a file on your actual computer that you can upload here.

  3. Check neofetch: This prints out useful information about the game, the run-time, and your hardware, that’s useful for troubleshooting. It also tells you how much host RAM that the run-time is using, which is helpful for diagnosing memory leaks.

Know where things are stored

You may need to know where certain data for the game is stored.

The Executable Path is the directory where Steam downloads the game to. You can use Steam’s UI to browse to this path. You’ll likely never need to, but it’s nice to know where it is.

The Hypervisor Path is where the game stores persistent settings and data specific to the host system.

  • On Windows: C:\Users\Username\AppData\LocalLow\Alkaline Thunder\Socially Distant
  • On Linux: ~/.config/unity3d/Alkaline Thunder/Socially Distant


The Registry is where all game settings are stored, such as graphics and audio preferences. This is located in Hypervisor Path/settings.xml. In extremely rare cases, you may need to edit this. But you should not do so unless I or another developer specifically tells you to. You should instead stick to using the registryctl command in-game or the game’s settings UI. You have been warned, corrupting the registry will prevent the game from starting.

Do not share your full Registry file on this forum, it can contain sensitive information such as OAuth credentials or gameserver credentials. Instead, if we need to see your registry, you can use the registryctl dump --no-sensitive | hypervisorctl save-to-host in-game. This exports the Registry to an XML file, but without any sensitive data in it.

User-Created Content

If your game has Workshop content installed, see if the issue you’re having persists without the Workshop content active. Some content modifies how the game works, and that can cause unexpected issues.

Gradually re-enable Workshop content until you find the problematic asset. Then, please direct the issue to the Workshop item’s creator. If they identify a bug in the game, they’ll report it upstream to us.

When starting a support thread…

If nothing you’ve tried above actually resolves the problem, it’s time to take it further.

First, look for existing support threads that describe the same issue. See if there’s a solution in one of the threads that works for you. If it does, like the post so the rest of the community knows.

If an existing post describes your issue but there are no solutions that work, contribute to that post with your own diagnostic data (dmesg, neofetch, etc.). Please don’t start a new thread, or simply reply with “i’m having the same issue too.”

When starting a new thread, please be descriptive of the issue. What’s happening? What were you doing when it happened? What did you expect to happen? Have you tried on other devices or platforms? What have you tried to resolve the issue?

Hi my computer won’t turn on how to fix

@TobiasSN Okay so what you wanna go ahead and do is go ahead and grab that drill press over there and uhhhh…Yeah. You know the rest.

The drill press is demanding a raise and threatening to unionize with the other tools, what do I do?

Get another drill press and have it press the other tools while the original drill press watches. It has no human rights and must be taught a severe lesson for going out of line.

The new drill press sympathized with the other tools, and they are now starting an uprising against humanity. Maybe I should just buy a new computer?

That might work. Or you can disassemble the tools into raw materials, start a chip fab, and build your own PC from the dust.

Tried that, but they all turned into potato chips instead of microchips???

Potatoes are capable of conducting electricity. Take advantage of the fact they can rot, and start a tech company whose business model is built around planned obsolescence. Call it…uhhhh…Potato Inc.

Just remember, slice different.